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Objective

The objective of this exercise is to explore and learn basic functions in HEC-GeoRAS for
pre- and/or post-processing of GIS data and HEC-RAS results for flood inundation
mapping using ArcGIS 10.x. It is expected that you are familiar with HEC-RAS and
ArcGIS. If you want to get into details of HEC-GeoRAS that are not covered in this
tutorial please refer to the HEC-GeoRAS users manual.

Computer Requirements

You must have a computer with windows operating system, and the following programs
installed:

1. ArcGIS 10.x
2. HEC-GeoRAS
3. HEC-RAS

You can download HEC-RAS and HEC-GeoRAS (appropriate for your 10.x ArcGIS
version) for free from the US Army Corps of Engineers Hydrologic Engineering Center
website http://www.hec.usace.army.mil/software/

Data Requirement

The only essential dataset required for HEC-GeoRAS is the terrain data (TIN or DEM).
Additional datasets that may be useful are aerial photograph (s) and land use information.
The dataset supplied with this tutorial includes a small portion of the fictional Baxter
River available with HEC-GeoRAS users manual.

The data (11.1 MB) required for this tutorial are available at the following link:

ftp://ftp.ecn.purdue.edu/vmerwade/download/data/georasdata.zip

Download the zip file on your local drive, and unzip its contents. The GeoRASData
folder contains one sub-folder, one TIN dataset, and one aerial image (as raster grid) as
shown below (ArcCatalog view):
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The LandUse folder contains a shapefile with land use data, aerial is the aerial image of
the study area, and baxter_tin is the TIN dataset for the study area.

Getting Started

Start ArcMap by clicking Start-> Programs—>ArcGIS—>ArcMap. Save the ArcMap
document (by clicking File->Save As..) as baxter_georas.mxd in your working folder.

Since Hec-GeoRAS uses functions associated with ArcGIS Spatial Analyst and 3D
Analyst extensions, make sure these extensions are available, and are enabled. You can
check this by clicking on Customize->Extensions.., and checking the boxes (if they are
unchecked) next to 3D Analyst and Spatial Analyst as shown below:
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Close the Extensions window.

Now load the HEC-GeoRAS toolbar into ArcGIS by clicking on
Customize—=>Toolbars=>HEC-GeoRAS to see the toolbar as shown below:
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You can either leave the HEC-GeoRAS toolbar on the map or dock it with other toolbars
as desired.

The HEC-GeoRAS toolbar has four menus (RAS Geometry, RAS Mapping, ApUltilities,
Help) and seven tools/buttons (Assign RiverCode/ReachCode, Assign
FromStation/ToStation, Assign LineType, Construct XS Cutlines, Plot Cross Section, and
Assign Levee Elevation) as shown in circles and boxes, respectively in the figure below.



HEC-13e0RAS |

RAS Geometry ¥ RASMapping ¥ ¢ of 1] &F == <= £ apltities v Help =
| 1 | |
L] L] L) L]
L+] [5] [s] 7]

The RAS Geometry menu contains functions for pre-processing of GIS data for input to
HEC-RAS. The RAS Mapping menu contains functions for post-processing of HEC-RAS
results to produce flood inundation map. The ApUtilites menu contains functions mainly
for data management. The Help menu is self-explanatory. You will learn more about the
functions associated with these menus and buttons in the following sections.

Setting up Analysis Environment for HEC-GeoRAS

Using GIS for hydrologic/hydraulic modeling usually involves three steps: 1) pre-
processing of data, 2) model execution, and 3) post-processing/visualization of results. To

create a geometry file, you need terrain (elevation) data. Click on Add + button in
ArcMap, and browse to baxter_tin to add the TIN to the map document. You must have
the same coordinate system for all the data and data frames used for this tutorial (or any
GeoRAS project). Because baxter_tin already has a projected coordinate system, it is
applied to the data frame. You can check this by right-clicking on the data frame and
looking at its properties. Next, click on RAS Geometry—> Layer Setup. Select baxter_tin
as the single TIN in the Required Surface tab, and click OK.
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Creating RAS Layers

The geometry file for HEC-RAS contains information on cross-sections, hydraulic
structures, river banks and other physical attributes of river channels. The pre-processing
using HEC-GeoRAS involves creating these attributes in GIS, and then exporting them to
the HEC-RAS geometry file. In HEC-GeoRAS, each attribute is stored in a separate
feature class called as RAS Layer. So before creating river attributes in GIS, let us first
create empty GIS layers using the RAS Geometry menu on the HEC-GeoRAS toolbar.
Click on RAS Geometry—->Create RAS Layers. You will see a list of all the possible
attributes that you can have in the HEC-RAS geometry file. If you wish, you can click on



individual attribute to create a single layer at a time, or you can click on All to create all
layers. For this tutorial, click on ALL to create all layers.
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In the Create All Layers window, accept the default names, and click OK.
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HEC-GeoRAS creates a geodatabase in the same folder where the map document is
saved, gives the name of the map document to the geodatabase (Baxter_georas.mdb, in
this case), and stores all the feature classes/RAS layers in this geodatabase.



After creating RAS layers, these are added to the map document with a pre-assigned
symbology. Since these layers are empty, our task is to populate some or all of these
layers depending on our project needs, and then create a HEC-RAS geometry file.

Creating River Centerline

Let us first start with river centerline. The river centerline is used to establish the river
reach network for HEC-RAS. The baxter_tin dataset has the Baxter River flowing from
east to west with Tule Creek as a tributary. So there are three reaches: upper Baxter
River, lower Baxter River and Tule Creek Tributary as shown below:
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We will create/digitize one feature for each reach approximately following the center of
the river, and aligned in the direction of flow. Zoom-in to the most upstream part of the
upper Baxter reach to see the main channel (black outline shown in the above figure).

To create the river centerline (in River feature class), start editing. In the create features
window, select River for features and Line for construction tools as shown in the figure
below. (Note: While digitizing the centerline, make sure that you leave some space
between the boundary of the dataset and the beginning/ending of your centerline.)
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Using the straight segment tool on the Editor, start digitizing the river centerline from
the upstream end of the upper Baxter River reach towards the downstream until you reach
the intersection with the Tule Creek tributary. When you reach the intersection, double
click to complete the centerline for the upper reach. If you need to pan, click the pan tool,
pan through the map and then continue by clicking the sketch tool (do not double-click
until you reach the junction). After finishing digitizing the upper Baxter Reach, save the
edits. Before you start digitizing the Tule Creek tributary, modify some editing options.
Click on Editor-> Snapping ->Snapping Toolbar, and select the check the End Snapping
option as shown below. (Note: Setting the snapping options is not needed in ArcGIS
versions 10.2 and higher because the editing digitizing tool will snap automatically to the
end of an existing line)




End Snapping

We are selecting this snapping option because when we digitize the Tule tributary we
want its downstream end coincide with the downstream end of the upper Baxter Reach.
Now start digitizing the Tule Tributary from its upstream end (leave some space from
the edge!) towards the junction with the Baxter River. When you come close to the
junction, zoom-in, and you will notice that the tool will automatically try to snap (or
hug!) to the downstream end of the upper Baxter Reach. Double click at this point to
finish digitizing the Tule Tributary. Save edits. Finally, digitize the lower Baxter reach
from junction with the Tule Tributary to the most downstream end of the Baxter River
(again leave some space from the edge!). Again make sure you snap the starting point
with the common end points of Upper Baxter Reach and Tule Tributary. Save edits, and
stop editing. Snapping of all the reaches at the junction is necessary for connectivity and
creating a junction that HEC-RAS will use to define the intersection of these lines.

After the reaches are digitized, the next task is to name them. Each river in HEC-RAS
must have a unique river name, and each reach within a river must have a unique reach
name. We can treat the main stem of the Baxter River as one river and the Tributary as
the second river. To assign names to reaches, click on Assign RiverCode/ReachCode
button to activate it as shown below:
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With the button active, click on the upper Baxter River reach. You will see the reach will
get selected, invoking the following window:
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Assign the River and Reach name as Baxter River and Upper Reach, respectively, and
click OK. Click on the tributary reach, and use Tule Creek and Tributary for River and
Reach name, respectively. For lower Baxter River, use Baxter River and Lower Reach for
River and Reach name, respectively.



Now open the attribute table of the River feature class, and you will see that the
information you just provided on river and reach names is entered as feature attributes as

shown below.
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Also note that there are still some unpopulated attributes in the River feature class
(FromNode, ToNode, etc.).

Before we move forward let us make sure that the reaches we just created are connected,
and populate the remaining attributes of the River feature class. Click on RAS
Geometry—-> Stream Centerline Attributes—> All
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Confirm River for Stream Centerline and baxter _tin for Terrian TIN, River3D for Stream
Profiles, and click OK. This function will populate the FromNode and ToNode attribute
of the River feature class. This will populate all attributes in River, and will also create
3D version (new feature class) of River centerline called River3D. Now open the attribute
table for River, and understand the meaning of each attribute.
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HydrolD is a unique number for a given feature in a geodatabase. The River and Reach
attributes contain unique names for rivers and reaches, respectively. The FromNode and
ToNode attributes define the connectivity between reaches. ArcLength is the actual length
of the reach in map units, and is equal to Shape_Length. In HEC-RAS, distances are
represented using station numbers measured from downstream to upstream. For example,
each river has a station number of zero at the downstream end, and is equal to the length
of the river at the upstream end. Since we have only one reach for Tule Creek tributary
the FromSta attribute is zero and the ToSta attribute is equal to the ArcLength. Since the
Baxter River has two reaches, the FromSta attribute for Upper Reach = ToSta attribute of
lower reach, and the ToSta attribute for upper reach is the sum of ArcLengths for the
upper and lower reach. Close the attribute table, and save the map document.

Creating River Banks

Bank lines are used to distinguish the main channel from the overbank floodplain areas.
Information related to bank locations is used to assign different properties for cross-
sections. For example, compared to the main channel, overbank areas are assigned higher
values of Manning’s n to account for more roughness caused by vegetation. Creating
bank lines is similar to creating the channel centerline, but there are no specific guideless
with regard to line orientation and connectivity - they can be digitized either along the
flow direction or against the flow direction, or may be continuous or broken.

To create a bank line (in Banks feature class), follow the same digitization procedure by
selecting bank feature and straight segment tool. Although there are no specific
guidelines for digitizing banks, to be consistent, follow these guidelines: 1) start from the
upstream end; 2) looking downstream, digitize the left bank first and then the right bank.
When digitizing the left bank, you do not have to stop at the intersection, you can have a
single bank for the whole reach. One the right hand side, however, you cannot cross the
creek so you will need two separate lines for the right bank of the Baxter River. Digitize
banks for all three reaches and save the edits and the map document.

Creating Flowpaths

The flowpath layer contains three types of lines: centerline, left overbank, and right
overbank. The flowpath lines are used to determine the downstream reach lengths
between cross-sections in the main channel and over bank areas. If the river centerline
that we created earlier lie approximately in the center of the main channel (which it does),
it can be used as the flow path centerline. Click on RAS Geometry—> Create RAS
Layers—>Flow Path Centerlines

Click Yes on the message box that asks if you want to use the stream centerline to create
the flow path centerline. Confirm River for Stream Centerline and Flowpaths for Flow
Path Centerlines, and click OK.



Create Flow Paths

Stre.arn Centerling | River w |
Flows Path Centerlines |Flnwpaths |
[ (1] 4 ] [ Help ] [ LCancel ]

To create the left and right flow paths in Flowpaths feature class, start editing. Digitize
flowpaths using the same digitization procedure as before. The left and right flowpaths
must be digitized within the floodplain. These lines are used to compute distances
between cross-sections in the over bank areas. Again, to be consistent, looking
downstream, first digitize the left flowpath followed by the right flowpath for each reach.
After digitizing, save the edits and stop editing. (Note: Make you digitize right and left
flow path separately for each individual reach. Do not use a common flowpath line for
multiple reaches.)

Now label the flowpaths by using the Assign LineType button L1 Click on the button
(notice the change in cursor), and then click on one of the flow paths (left or right,
looking downstream), and name the flow path accordingly as shown below:
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Label all flow paths, and confirm this by opening the attribute table of the Flowpaths
feature class. The LineType field must have data for each row if all flowpaths are labeled
as shown below.
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Creating Cross-sections

Cross-sections are one of the key inputs to HEC-RAS. Cross-section cutlines are used to
extract the elevation data from the terrain to create a ground profile across channel flow.
The intersection of cutlines with other RAS layers such as centerline and flow path lines
are used to compute HEC-RAS attributes such as bank stations (locations that separate
main channel from the floodplain), downstream reach lengths (distance between cross-
sections) and Manning’s n. Therefore, creating adequate number of cross-sections to
produce a good representation of channel bed and floodplain is critical. Certain
guidelines must be followed in creating cross-section cutlines: (1) they are digitized
perpendicular to the direction of flow; (2) must span over the entire flood extent to be
modeled; and (3) always digitized from left to right (looking downstream). Even though
it is not required, but it is a good practice to maintain a consistent spacing between cross-
sections. In this exercise, lets use an approximate spacing of 150 meters (500 feet) for all
cross-sections. In addition, if you come across a structure (eg. bridge/culvert) along the
channel, make sure you define one cross-section each on the upstream and downstream of
this structure. The upstream and downstream cross-sections must be no farther than 100 —
200 feet from the structure. Structures can be identified by using the aerial photograph
provided with the tutorial dataset. For example, we will use one bridge location in this
exercise just downstream of the junction with tributary as shown below (bridge location
is shown in red):

11



To create cross-section cutlines in XSCutlines feature class, start editing. Digitize cross-
section cutlines by using the same digitization procedure as before, but follow the
guidelines outlined in the previous paragraph. While digitizing, make sure that each
cross-section is wide enough to cover the floodplain. This can be done using the cross-

sections profile tool ™ . Click on the profile tool, and then click on the cross-section to
view the profile. For example, if you get a cross-section profile shown in Figure A below,
then there is no need to edit the cross-section, but if you get a cross-section as shown in
Figure B below, then the cross-section needs editing. (Note: This tool stops the edit
session so you will have to start the edit session every time after viewing the cross-
section profile). If using the profile tool does not help you, make sure your cross-section
is at least four to five times wider than the channel banks.
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After digitizing the cross-sections, save the edits and stop editing. The next step is to add
HEC-RAS attributes to these cutlines. We will add Reach/River name, station number
along the centerline, bank stations and downstream reach lengths. Since all these
attributes are based on the intersection of cross-sections with other layers, make sure each
cross-section intersects with the centerline and overbank flow paths to avoid error
messages.
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Click on RAS Geometry—> XS Cut Line Attributes—> River/Reach Names. This tool uses
the River and Reach attributes of the centerline, and copy them to the XS Cutlines. Next,
click on RAS Geometry-> XS Cut Line Attributes—> Stationing. This tool will assign
station number (distance from each cross-section to the downstream end of the river) to
each cross-section cutline. Next, click on RAS Geometry—>XS Cut Line Attributes—=> Bank
Stations. Confirm XSCutlines for XS Cut Lines, and Banks for Bank Lines, and click
OK.
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This tool assigns bank stations (distance from the starting point on the XS Cutline to the
left and right bank, looking downstream) to each cross-section cutline. Finally, click on

RAS Geometry—> XS Cut Line Attributes->Downstream Reach Lengths. This tool assigns
distances to the next downstream cross-section based on flow paths.

The cross-section cutlines are 2D lines with no elevation information associated with
them (Polyline). When you used the profile tool earlier to view the cross-section profile,
the program used the underlying terrain to extract the elevations along the cutline. You
can convert 2D cutlines into 3D by clicking RAS Geometry—>XS Cut Line
Attributes—>Elevation. Confirm XSCutlines for XS Cut Lines, and baxter_tin for Terrian
TIN. The new 3D lines (XS Cut Lines Profiles) will be stored in the XSCutLines3D
feature class. Click OK.
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After this process is finished, open the attribute table of XSCutLines3D feature class and
see that the shape of this feature class is now PolylineZ.

Creating Bridges and Culverts

After creating cross-sections, the next step is to define bridges, culverts and other
structure along the river. Since we used aerial photograph while defining the cross-
sections, our job of locating the bridge accomplished. To create bridges/culverts (in
Bridges feature class), start editing to digitize bridges. A bridge or culvert is treated
similar to a cross-section so the same criteria used for creating cross-sections must be
used for bridge/culverts. Using Bridge as the edit feature and the straight segment tool on
the editor toolbar, digitize bridge location just downstream of the tributary junction.
While digitizing the bridge, make use of the terrain model to make sure the bridge/road
centerline fall on the high ground. Save your edits and stop editing.

After digitizing bridges/culverts, you need to assign attributes such as River/Reach name
and station number to these features. Click on RAS Geometry—> Bridge/Culverts—>
River/Reach Names to assign river/reach names. Next click on RAS Geometry—>
Bridge/Culverts—>Stationing to assign station numbers. Besides these attributes, you must
enter additional information about the bridge(s) such as the name and width in its
attribute table as shown below.
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Close the attribute table, save edits and stop editing.

Similar to cross-sections, the Bridges feature class stores 2D polylines, you can make
them 3D by clicking RAS Geometry->Bridge/Culverts->Elevations to create a new
3DBridges feature class. Confirm Bridges for Bridges/Culverts, baxter_tin for Terrain,
Bridges3D for Bridges/Culverts Profiles, and Click OK.
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A new feature class (Bridges3D) will be created. You can check it is PolylineZ by
opening its attribute table.

Creating ineffective flow areas

Ineffective flow areas are used to identify non-conveyance areas (areas with water but no
flow/zero velocity) of the floodplain. For example, areas behind bridge abutments
representing contraction and expansion zones can be considered as ineffective flow areas.
To define ineffective areas (in IneffAreas feature class), start editing, and choose
IneffAreas as the edit feature, and Polygon as the construction tool.

Create Features
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Use the sketch tool to define ineffective areas. The figure below shows an example of
ineffective area for the bridge downstream of the tributary junction (Note: this is a
polygon feature class).

HEC-RAS does not store all information about ineffective areas. Instead only the
information where the ineffective area may interfere with cross-sections/flow is stored.
Therefore, it is important that the ineffective flow area that you digitize must intersect
with one or more cross-sections. To extract the position and elevation at points where
these ineffective areas intersect with cross-sections, click on RAS Geometry-> Ineffective
Flow Areas—>Position. Leave the default feature classes for IneffectiveAreas, XS Cut
Lines, and Terrain unchanged. The position of ineffective areas will be stored in a new
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table named IneffectivePositions. Leave current user elevations unchecked, and Click
OK.
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Open the attributes of the IneffectivePositions table (shown below) to understand how
this information is stored. If you cannot find this table in the map document, add it
manually from the geodatabase where all your other layers are stored.

- R By O X

IneffectivePasitions

| OBJECTID * }l{S:ZDI[I| 1AZDID | BegFrac | EndFrac | BegElev | EndElev UserElev

» | 1 18 36 063724 083237 45913 G0.441 |=Mull=
J 2 18 ar 0.37743 044731 ar 22T 523.251 |=Mull=
J 3 iy s 066403 0.g2444 439 233 BO0.427 |=Mull=
J 4 iy 39 0.343505 0477 2962 35.507 |=Mull=

14 4 1 F b E {0 out of 4 Selected)

{IneffectivePositions i

IA2DID is the HydrolD of the ineffective flow area, XS2DID is the HydrolD of the
intersecting cross-section, BeginFrac and EndFrac are the relative positions of the first
and last intersecting points (looking downstream) of the ineffective area with the cross-
section. BegElev and EndElev are the elevations of the first and last intersecting points of
the ineffective area with the cross-section. Since you left the UserElev box unchecked
there are no values in this field.

Creating obstructions

Obstructions represent blocked flow areas (areas with no water and no flow). For
example, buildings in the floodplain and levees are considered obstructions. We can add
blocked obstructions to our study by using building locations in the aerial photograph. In
the upper reach of the Baxter River just before Tule Creek, there are two building in the
floodplain that can be considered as blocked obstructions.
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To define blocked obstructions (in BlockedObs feature class), start editing, and choose
BlockedObs as the edit feature and Polygon as the construction tool.

Using the straight segment tool, digitize the blocked obstruction polygon, save edits and
stop editing. Similar to Ineffective flow areas, the positions and elevations of the
intersection of this obstruction with cross-sections needs to be stored in a table. Click on
RAS Geometry—> Blocked Obstructions—> Positions. Leave the default values in the
Blocked Obstructions window, and click OK. You will notice that a new table
(BlockedPositions) will be added to the map document, and its content are identical to
IneffectivePositions table.

Assigning Manning’s n values to cross-sections

The final task before exporting the GIS data to HEC-RAS geometry file is assigning
Manning’s n values to individual cross-sections. In HEC-GeoRAS, this is accomplished
by using a land use feature class with Manning’s n stored for different land use types.
Ideally you will store this information in the LandUse feature class added to the map
document. Since we created empty feature classes at the beginning of the tutorial, we do
not have this information. We will remove this empty LandUse feature class, and add
LandUse shapefile (stored in LandUse folder) provided with the tutorial dataset. (Note:
you can also replace the LandUse feature class in Baxter_georas.mdb with the shapefile
in ArcCatalog)
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Table

ERAL AL R

LandUse

| H_Value | Shape_Leng |

B

=

Shape_Area |~

FID | Shape' | LUCode

n 0| Palygon Mearstream
n 1 |Palygon Mearstream
n 2 |Palygon Mearstream
n 3 |Palygon Urban
n 4 | Palygon Farming
n 5 | Palygon Urban
n 6 |Paolygon Urban
n 7 | Palygon Farming
n 3 |Paolygon Farming

9 | Palygon Urban

4 4

LandUse

0035
0035
0035

0.05
0.08
0.05
0.05
0.08
0.08
0.05

74235 039962
94595 536535
19499 635779
25155 599476
S7470. 779547
43729 452249
49435 5793506
95673 544045
139480517374
77954 833646

27 OF M E {0 out of 90 Selected)

475534074 2645
Tr091525 35925
3890744 91706
I73E0VED 6827
132969465.043
0210914 7352
131147302.076

SB9365177 1
282945502797

194373174 064 | %

The land use table must have a descriptive field identifying landuse type, which is
LUCode in this case, and a field for corresponding Manning’s n values. In addition,
HEC-GeoRAS requires the land use polygons to be non multi-part features (a multipart
feature has multiple geometries in the same feature). The issue of non multi-part features
is taken care of for the tutorial dataset.

To assign Manning’s n values to cross-sections, click on RAS Geometry—=> Manning’s n
Values—>Extract n Values. Confirm LandUse for Land Use, choose N_Value for Manning
Field, XSCutLines for XS Cut Lines, leave the default name Manning for XS Manning
Table, and click OK. (Note: Summary Manning Table is not required if n values already

exist in the LandUse table.).

¥H Extract N Values @

Land U= | LandUse

Select Manning Option

(#) Manning Yalues in Landuse Layer

I atining Field | M_Value

(") Table of Manning Values
Landuze Field

tanning T able

5 Culines XSCutLines

®5 Manning T able |Manning

0K ” Help ” Cancel
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Depending on the intersection of cross-sections with landuse polygons, Manning’s n are
extracted for each cross-section, and reported in the XS Manning Table (Manning). Open
the Manning table, and see how the values are stored. Similar to previous tables, the data
are organized as the feature identifier (XS2DID), its relative station number and the
corresponding n value as shown below:

OBJECTID * | XS2DID | Fraction | N_Value
| 1 14 0 0.05
| 2 14 0.20915 0.035
| 3 15 0 0.05
| 4 15 0.25045 0.035
| 5 15 0.75365 0.05
| B 16 0 0.05
| 7 16 0.11408 0.035
| 8 16 0.50653 0.05
| 3 17 0 0.05
| 10 17 017139 0035, o
14 4 2k b E {0 out of 22 Selected)
Hanning

Close the table. We are almost done with GeoRAS pre-processing. The last step is to
create a GIS import file for HEC-RAS so that it can import the GIS data to create the
geometry file. Before creating an import file, make sure we are exporting the right layers.
Click on RAS Geometry-> Layer Setup, and verify the layers in each tab. The required
surface tab should have baxter_tin for single Terrain option.

.............................................

_ Temain Type f* TIM " Grid
% Single
Select Terrain II:na:-:ter kit j
" Muliiple DTH Tiles Layer IN”" =l

The Required Layers tab should have River, XSCutLines and XSCutLines3D for Stream
Centerline, XSCutmLines and XSCut Lines Profiles, respectively.
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Layer Setup

Reguired Surface

I Optiohal Layers I Optiohal Tables I

Stream Centerline

#5 Cut Lines

I River

[ <SCutLines

%S Cut Lines Profiles IXSEutLinESED

In the Optional Layers tab, make sure appropriate layers are assigned.

Ef; Layer Setup for HEC-RAS PreProcessing @

| Required Surface | Required Layers |Op‘t|onaILa','ers| Optional Tables
Bank Lines [Eanks v] Stream Profiles [F{jverBD v]
Flow Path [Flowpaths '] Storage Areas [Stolageﬂreas v]
Land Use [Land Use '] Storage Points [Null ']
Levee Alignment [Levees v] Levees Profiles [Null v]
Ineffective Flow [Ineﬁ'ﬂreas v] Levee Points [LeveePoirrts v]
Blocked Obstructions | BlockedObs =] Bank Points [Nl v
Eridges/Culverts [ Bridges - ] Brnidges/Culverts Profiles [ Mull - ]
Inline Structures [InlineStn.lctures v] Inline Structures Profiles [Null v]
Lateral Structures [LatemlStn.ldures V] Lateral Structures Profiles [Null v]
5A Connections [Sﬁ.Connections - ] 54 Connections Profiles [ Null hd ]

[F] Apply HEC-GeoRAS Symbology ’ oK ] [ Help ] [ — ]

Finally, verify optional tables and Click OK.

g

E Layer Setup for HEC-RAS PreProcessing

Elevation Vaolume

Modes Table

Manning [I'H'Ianning v]
Leves Positions [Null v]
Ineffective Positions [ Ineffective Posttions - ]

Blocked Obstructions [ BlockedPostions

[ Nl

[ ModesTable
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One final and most important step before proceeding further is the data check, which we
will do manually. Do the checks on the following feature classes:

River: Open the attribute table of River, and make sure all the attributes are correctly
populated. Check the connectivity of the centerlines and make sure there are no negative
or invalid numbers for any fields.

Flowpaths: Open the attribute table for Flowpath, and make sure that that the LineType
field is populated and that the line types are correct. For example, Left should represent
the left flowpath and Right should represent the right flowpath for each reach.

XSCutlines: Open the attribute table for XSCutline, and make sure that all the attributes
are populated. Make sure that all numbers are positive for StationNo, RLenth, LLength
and ChLength fields. If any number for RLength or LLength is negative for any cross-
section, that cross-section was most likely digitized in the wrong direction. Go back and
flip that cross-section, and re-assign the attributes. Do this for all cross-sections that have
negative numbers for RLength or Length.

Tables: Open all the tables (BlockedObs, IneffectiveAreas and Manning to make sure
they are populated)

After verifying all layers and tables, click on RAS Geometry—>Export RASData. Confirm
the location and the name of the export file (GIS2RAS in this case), and click OK. During
the export, you will see a series of messages as shown below.

Export RAS Data E]
RAS File | D:vAre] Dvgeoras\GIS 2RAS
Mezzages
A
Start Time ?y&p&:age M ezzage
1258 P [nfarmative Workzpace for DAARCIOVGEORAS\BAXTER_GEQRAS MDE h...
12:58 P Infarmative pdated contral file lnaded to exparter: C:A\Documentz and Settin,.
12:58 P [nfarmative Intermediate #ML file name iz D:\Ae1Dhgearaz\GIS 2RAS TmpFil..
12:58 PM Informative Creating export work.space
12:58 P [rfarmative Ewport wark zpace created
1258 P [nfarmative Exporting data from D:AARCI0MGEORASBAXTER_GEORAS M. ..
12:58 PM Irformative Proceszzing GeDE Model Walues
12:58 P [nformative Starting to export G15 data from geodatabaze
12:58 PM Informative Still exporting...
12:58 P Infarmative River haz been exported
12:58 P [nfarmative #5Cutlines has been exported
L
Help l [ Cloze
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After the export is complete, close the window. This process will create two files:
GIS2RAS.xml and GIS2RAS.RASImport.sdf. Click OK on the series of messages about
computing times. You are done exporting the GIS data! The next step is to import these
data into a HEC-RAS model.

The final layers in ArcMap should look something like the figure below.
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(Note: Purdue students or others doing this exercise in one of my workshops, please let
me see your data before closing the map document! It will save a lot of your time and my
time in finishing this exercise successfully!)

Save the map document. You can either close the ArcMap session or leave it open
(recommended!).

Importing Geometry data into HEC-RAS

Launch HEC-RAS by clicking on Start->Programs->HEC—->HEC-RAS>HEC-RAS 4.0.
Save the new project by going to File->Save Project As.. and save as baxter.prj in your
working folder as shown below:

Save Project As

Title File Mame
IFI::n:u:I ztudy for B aster River Iba:-:ter.pri
Click OK.

To import the GIS data into HEC-RAS, first go to geometric data editor by clicking on
Edit-> Geometric Data... In the geometric data editor, click on File=>Import Geometry
Data—> GIS Format. Browse to BaxterRAS.RASImport.sdf file created in GIS, and click
OK. The import process will ask for your inputs to complete. In the Intro tab, confirm US
Customary Units for Import data as and click Next.
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Current BAS project units:

Irpart data as:

| US Custornary Urits

™ 5 [metric) units

Impart data will not be ¢

ted on import.

Confirm the River/Reach data, make sure all import stream lines boxes are checked, and
click Next.

Intio  River Reach Stream Lines I Cross Sections and 1B Nodes | Storane freas and Connections |

ou want ko import,

with the

Impoit File Impaort File [nvert | Import Az Import &z Import | Import Merge Mode
River Reach HBPaintz | River Reach Statuz | Stream Lines

1| Bauter River Upper Reach (178 Banter River Upper Reach | new I Replace

2| Baxter Biver | Lower Reach | 330 Bauter River | Lower Reach 7 Replace

3| Tule Creek Tributary 182 Tule Creek, Tributary niE W Feplace

Confirm cross-sections data, make sure all Import Data boxes are checked for cross-
sections, and click OK (accept default values for matching tolerance, round places, etc).

Impork Options

Introl River Beach Stream Lines  Crazz Sections and |B Modes I Storage Areas and Connechions I

j Import Ag: | # new RS =172 [# new RS to import = 172]
| Check Mew |

Impaort River:

Impart Reach:

[l Rivers]

PP, | Iricort A

Check E:-ustlng |  Reset |

The imported RS can be edited here, change the import River and Reach na
Import File Import File Impart File Import A3 Import | Import
River Reach RS RS Statuz | Data
1| Baster River Upper Reach 9561054 9861054 FIEW v
2| Baster River Upper Reach 94782 74 9478274 =0 v
3| Baster River Upper Reach 94338 26 94338.26 FIE v
4| Baster River Upper Feach 94151.10 94151.10 et i
5| Bawter River Upper Feach 93759 42 9378942 el i
G| Baxter River Upper Reach 93394.89 93394.89 nEw v
7| Baster River Upper Reach 92746 22 9274622 new v
8| Baster River Upper Reach 92504 42 92004 42 FIEW v
9| Baster River Upper Reach 9206968 92069.68 FIEW v
10| Baster River Upper Reach 9175110 9175110 FIE v b
to Irmport — Match Import File RS to Existing Geometm RS ———
V¥ Mode Mames IV Ineffective Areas I atching Talerance Im_ Match ba Existing |
™ Descriptions ¥ Blocked Obstructions
I~ | Ficture Fieferences I~ 5 Lids — Round Selected RS
¥ GIS Cut Lines I~ lceData |2 decimal places j Raund |
[+ Station Elevation D ata I™ Bating Curves
¥ Reach Lengths I™ Skewdéngle — Generate BS Bazed o main channel [enaths
v anring's nValues I™ Fized Sediment Elevation [anly available when looking at a single reach)
[+ Barlk Stations I™ HTjak Rarameters Starting RS Walue: |D |2 decimal pIac:J
[™ Contraction Expansion Cosf [T Filab Channel Parameters Cieate RS in miles I Create BS in feat |
I~ Levess

Previousl [t | Finizhed - Impart D ata I Cancel |

Since we do not have Storage areas, click Finished-Import Data. The data will then be
imported to the HEC-RAS geometric editor as shown below:
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Edit existing junctions — IEllll
File Edit Yiew Tables Tools Help
Tools | River |Storage | S.A. Pump RS
Reach | Area Conn. | Station
FN = -|d—' [0l | SSTE #
Jurct. =
®
Cross
Section
\_\_‘,_(' 4045 675
Bria/Cu e 3639317
rdg,Culu
= FiRgTas
= - 2355.087
Irlire Sy 1853590
Sitructure 3 ‘-',,_'
Lateral
Structure L
[~ ~ =] b e 8 ]
] SR
o 4101 544863280
- 46533 69 e,
Storage Reach
poworage 43639.22 17 ‘ e g
| 514967
Pump 4541096 S1EB08 |
Station 45033 66 52675.99 J—
& -
HTah
Param =
virw L LlJ
6417952.00, 2055400.00 |

Save the geometry file by clicking File->Save Geometry Data. Before you proceed, it is
a good practice to perform a quality check on the data to make sure no erroneous
information is imported from GIS. You can use the tools in Geometric editor to perform
the quality check. One of the best tools for editing cross-sections in HEC-RAS is the
graphical cross-section editor. In the geometric editor, go to Tools->Graphical Cross-
section Edit.

Graphic ¥5 Editor ] 4
File Options
River: IBaxter River [~ Persiztent Scale
Reach: ILower Fieach T ﬂ ﬂ [~ Compare Geometry Files
Description I [~ Merge Cross Sections
Bark Station Tools: “'LEll LB“‘l EI H +F|EI| HB"'
ke 05 i 035 I 05 —>| C
a0 Legendl
p———
G0 Grounc
-
Bank Sta
= 704
k=t
5
= B0 h
=
o
w SD -
401
30 T T T T 1
0 S00 1000 1500 2000 2500
Station () =
LI F
|Move Objects

You can use the editor to move bank stations, change the distribution of Manning’s n,
add/move/delete ground points, edit structure, etc. You can play around with these tools
and learn more about the functions.
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A cross-section in HEC-RAS can have up to 500 elevation points. Generally these many
points are not required, and also when we extract cross-sections from a terrain using
HEC-GeoRAS, we get a lot of redundant points. This issue can be handled by using the
cross-section filter in HEC-RAS. In the Geometric data editor, click on Tools—>Cross
Section Points Filter.

In the Cross Section Point Filter, select the Multiple Locations tab. From the River drop

down menu, select (All Rivers) option, and click on the select arrow button ﬂ to select
all cross-sections for all reaches. Then select the Minimize Area Change tab at the
bottom, and enter 250 for the number of points to trim cross-sections down to. The
minimize area change will reduce the impact of change in cross-sectional area as a result
of points removal. Click Filter Points on Selected XS button.

Cross Section Point Filter -0l x|

Single Location Multiple Locations I

Selected Locations [172 zelected]

Ee I[,.f_*.,|| Rivers) j Eauter River Upper Reack 9561054 ﬂ
Baster River Upper Reach 3478274
Heach:l j Bauster River  Upper Reach  34333.26
) - Baxter River  Upper Reach  34151.10
River Sta.: | [All Rivers] Baxter River Upper Reach  93759.42

Bawter River Upper Reach 9333489
:I Baxter River  Upper Reach 9274622
Bauster River  Upper Reach 9265442
Bawter River Upper Reach  920839.53
Baster River  Upper Beackh  31751.10
Bauster River  Upper Reach 3146256
Baxter River Upper Reach 9120553
Baster River UpperBeach  90410.75
Baster River Upper Reach 839926 41
Baxter River  Upper Reach 8350326
Bauster River  Upper Reach  33093.53
Bawter River Upper Reach 8875254
Baster River Upper Reach 88110067 ;I

Mear and Colinear Filer  Minimize Area Change |

Mumber of paints b trim cross section dowe bo: |25|:| Filter Paints on Selectad %5 |

HestureKSl ] | Cancel I

|Enter the karget for point reduction procedure.

You will get a summary of number of points removed for the filtered cross-sections. You
will notice that only a few cross-sections had points removal. Close the summary results
box. You can select the Single Location tab to see the effect of points removal on the
cross-sections.
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Next, click on the geometry editor and select any cross-section. You should see the cross-
section window as shown below (Note: Ignore the blue colored flow in the cross-section
profile):

IR o St L [E==rE—)
| Exit Edit Options Plot Help

River, [Baster Fiver v iz [==] + e ElotOotions Ba| G| I KeepPrev s Piots _Clear Prev |

Reach: [Upper Reach | River Sta. [3732.901 B Plan:

Desciption | =™

Del Row

Ins Fiow
dina

Downstream Reach Lengths

LOE Channel ROB

035 |

Legend
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54E.43 511.64 507,83
M anning's h ' alues
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Edit Station Elevation Data (1

Each cross-section in HEC-RAS has the following information:

Location: This is described by using three pieces of information: River, Reach and River
Station. The cross-section in Figure is located at a distance of 84816 ft (River Sta.) on the
Upper Reach (Reach) of the Baxter River (River) from the most downstream end of the
Baxter River.

Elevation Profile: This is the profile view that you see on the right hand side in the cross-
section window. This profile is created by using the information from the station and
elevation columns in the Cross Section Coordinates table on the left. The numbers in the
station column shows the distance along the cross-section from left to right (looking
downstream along the flow direction), and the elevation column shows the elevation at
each station point. You can think of Station and Elevation as the (x,z) attributes for the
cross-section line. Each station/elevation point is represented by a black dot on the cross-
section profile.

Bank locations: These are represented by two red dots on the cross-section profile. The
location of these red dots is dictated by the station numbers for Left and Right Banks in
the “Main Channel Bank Stations” table in the cross-section window.

Roughness (Manning’s n Values): The horizontal line at the top of the cross-section
profile shows the distribution of Manning’n value along the cross-section. This
distribution is defined in the n Val column in the Cross Section Coordinates table. You
will see that the n Val column is not populated for each row. The values are only reported
at stations points where there is a change in the Manning’s n. For example, the
Manning’s n is 0.06 at the beginning stays constant until the next change to 0.035.
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Distance to the next downstream cross-section: This information is presented in the
Downstream Reach Lengths table. The numbers for LOB, ROB and Channel represent
the distances to the next downstream cross-section along the left over bank, right over
bank and channel, respectively. These distances are computed by using the flow path
features that are digitized in HEC-GeoRAS.

If you are wondering how this information gets into HEC-RAS, the figure below shows
the attribute table of XSCutline and the corresponding information in HEC-RAS. (Note:
this figure is for reference only to understand the connection between HEC-RAS and
GeoRAS. It is not for Baxter River)

Table O x

H-R- 0P

XSCuttines Lo 2] B |+
Shape * | Shape_Lengt] HydrolD | Station River Reach LeftBank [ RightBank ] LLength | ChLength | RLength | »
Polyline 1521.004807 5| T774.309 | MatsenDitch Lower Reac 0.495354 0.50189 | 517.2728 453.2037 | 3887723 _|
Polyline 1587 .200581 8 T7321.105 | MatsonDitch Lower Reac 0.455124 0.488225 | 4292737 391.6729 | 353.3876
Palyline 1956.35069 7| 6928432 | MatsonDitch Lower Reac 0.47378 0.478926 | 467.6574 417.8507 | 368.7138
Polyling 2166497029 8| 6511.582 | MatsonDitch | Lower Reac 0.539426 0.544042 | 335.7045 351.0277 | 337.0579
Polyline 2154755818 9| 6160.554 | MatsonDitch | Lower Reac 0.55381 0.553458 | 277.2473 431.4077 | 39586838 | »
1| 1 3
T 0+ » [E|S] 1outof 22 Selected)
g - = - —
== Cross Section Data o — ; "‘-? . | - = | G|
Exit Edit Options Plot Help
River | MatsonDitch - \,;; Plot Options @ ™ Keep Prev 5 Plots  Clear Prev
Reach: |Lower Reach River Sta.: | 7321.105 . j ﬂ ﬂ matsaon Plan:
Descripti e
escription | i El e I e |
Del Fow Ins Row | Dawnstream Reach Lengths 2894 R hl e |
T et LOB | Chanel | ROEB 1 Legend
Station | Elevation | n'al « |429-2? -|391-8?- |353-39 - 2a0] - Grcumd
_ 1|0 27343 |0.035 Manning's n Yalues 12) Bank Sta
_2[amn 278.98 LOB Channel ROB 27
31822 | Z7EE6 [ o [N z
R EEREE — — =
5| 36.44 270,44 tain Charnel Bank ..t.atn:un:z: % 2761
E 4555 2783 Left Bank Right Bank i
~7|s465 | z7em EEE - ST - | T
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S =

Editing Bridge Structure Data

Another main task that we want to do is to edit data related to structures. When you

import river geometry from HEC-RAS to HEC-GeoRAS, the bridge profile needs to be

edited to correct the geometry and structural details. Click on Bridge/Culvert editing
Brdg,/Cul.

button = and select the Railroad bridge on the Lower Reach of the Baxter River.
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Figure below shows a typical unedited bridge cross-section after import into HEC-RAS.

Bridge Culvert Data - Baxter Geomelry - IEIIZI
File Wiew Options Help
River: IBaxtar Riiver hd Apply [ata =+ i
Reach: [T ~| River sta: 7806202 Raio ¥ | ¥ 1|
Description I EI
Bounding=5's: 8315435 | 710.4705 |Dislance between: 121.02 [ft]
Rggg{j»;yl an RS=780.6202 Rairoadpstream (Bridge) El
U Legend
80
Pier E' 70 Ground
S B0
" Ineft
1 B 50 .
Sloping| W 40 Bank Sta
Abutment 30
x| =2
[u] 1000 2000 3000 4000
Biidge
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Approach a R5=T80 6202 RairoadDovwnstream (Bridge)
Culvert a0
= 70
Mulkipl g i
ultiple | &
Openng| 3 20
Analysis | w40
30
HTah 20
[ a 1000 2000 3000 4000
Station (1) =
Bridge R =
Design

[Select the Reach for Bridge/Culvert Editing

You will see the cross-section profile (black dots and black line) of the upstream or
downstream cross-section, ineffective area (green lines) and red line is the ground profile
of the bridge. The gray area which is basically blocking the flow is the bridge structure.
As you can see currently the bridge is not properly represented in this figure. What we
need to do here is define the elevation of the road and the opening through which the
water will flow. This is done by using the Deck/Roadway editor.

The data for Deck/Roadway for an unedited bridge cross-section is shown below.

r

Deck/Roadway Data Editor

“wdidth

W'eir Coef

Digtance

|40 |20 |26

Clear | Drel Fowy | Inz Row |

CopyUStoD5 |

Dovenshieam

|Jpstream

wieir Crest Shape
(@ Broad Crested
(" Ogee

Ok, Cancel

Station | high chard| low chord | Station | high chord| low chord | «
_1{n 83.64 0. 3384
N |__2[485 83.84 485 2384
_3|1453 83.64 1453 8384
41173 g3.64 17.81 3384
__5|27E3 83.64 27.63 3384
__B|3157 83.84 3157 2384
714217 83.64 4217 8384
B LERE A3 R4 1A A3 R4 ﬂ
1J.5 Embankment 55 0 D.5 Embankment 55 |0
Wweir Data
i Max Submergence: 0.9 Mir \w'eir Flow EL:

Enter distance between upstream cross section and deck/roadway. (i)

-
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(Note: The figures and the numbers need to be interpreted appropriately based on your
cross-section profile. Do not blindly use the same numbers that are presented here. They
may not work for you). The high chord column in the above figure basically defines the
top elevation of the bridge, and the low chord defines the elevation of the bottom of the
bridge deck. In the absence of any values for low chord, the elevations on the cross-
section profile are used as the low chord values. Therefore, in order to define an opening
for the bridge, we need to first know the details of the bridge, its top elevation, opening
height, etc. In this case (for the above figure only), let us assume that the bridge top
elevation is 84 ft and the bridge deck is 6 ft deep. Also assume that the bridge opening
starts at 2200 station and ends at 3400 station across the cross-section profile (this will
give a bridge opening of 1200 ft). With these assumptions, we will enter the new high
and low chord values as shown in the figure below. Click on the Copy US to DS button
to copy the information from upstream to downstream, and click OK. Note that this
information should generally be obtained from the field, but here we are assuming these
values to just see how the opening is defined in HEC-RAS.

Deck/Roadway Data Editor

Del Row I
Inz Flow |

Station [ high cherd| low chord | Station [ high chord| low chord
0. 84, 0. 84,
2200, 84, 2200. 84,

1

B

E T 78 2200 B4, 78
I R ) 300, B4 78
G EUET 300, (B4,
_Bl4000 84 4000, B4,

7

Tl

-

L5 Embankment 55 IEI 0.5 Embankment S5 ID

weir Data
Max Submergence: 0.95 Mir w'eir Flow EL I

Wieir Crest Shape

() Broad Crested
) Ogee

Ok I Cancel I Clear I Copy US to DS I

[Enter distance between upstream cross section and deck/roadway. [ft]

After the high and low chord values are defined, the new cross-section with the bridge
opening is shown below.
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Select the river for Bridge/Culvert Editing

Try to understand how the information we entered for high chord/low chord in the

Deck/Roadway editor got translated into the opening. Once the opening is defined, the

next step is to use the Bridge Design tool to enter pier information. We will assume three
Bridge

10 ft wide piers with a spacing of 300 ft. We can use the Bridge Design tool P==9n to

enter this information as shown below.

P N

Bridge Design Editor

Deck/Roadway
El af High Chord [Top af Road]
El of Lowe Chord

[ AddVertical \alls in Deck

Opening *idth [Blank for Chan)
[ Add Sloping Abutments

Side Slope H:1Y
Make Deck/Roadway |
Piers
Humber of Fiers 3

| pstream =5 Starting Station 2800
Dawnstream 5 Starting Station |2500

Pier Centerline Spacing 300

Fier ‘idth 10
Make Piers |
Cloge

L

Click on Make Piers, and then click Close. The bridge opening will look as shown in the
figure below:
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File View Options Help
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You need to know the actual bridge condition to be able to accurately enter this
information, but for this tutorial we have used our intuition (and creativity!) in designing
the bridge. After you are done editing the bridge data, close the bridge/culvert editor,
save geometry data and close the geometric editor. We are done with geometric data! The
next step is to enter flow data. For this tutorial we will run the model in steady state
condition.

Entering Flow Data and Boundary Conditions

Flows are typically defined at the most upstream location of each river/tributary, and at
junctions. There are situations where you need to define flows at additional locations, but
for this tutorial we will use a simple case. Each flow that needs to be simulated is called a
profile in HEC-RAS. For this exercise, we will create three hypothetical profiles.

In the main HEC-RAS window, click on Edit->Steady Flow Data. Enter 3 for number of
profiles, and click Apply Data. Enter hypothetical flow conditions for these profiles as
shown below:
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Steady Flow Data - Baxter flow file =10 x|

File ©ptions Help

Enter/Edit Mumber of Prafiles [2000 max): |3— Feach Boundary Conditions | Apply D ata |
Locations of Flow Data Changes

Riwver: IBa:-cter Riwer j

Reach: ILIpper Reach j River Sta.: | 9732901 j Add A Flow Change Location |

Flawy Change Location Prafile Mames and Flow R ates

River Reach RS FF 1 | pF 2 |FF 2

1| Barter River |Ipper Reach 97929010 | 24000 43000 S&000

2| Bauter River Lower Reach 114647 25000 A0000 100000
Tule Creek Tributary 4045 E7€] 1000 2000 anog

|E|:|it Steady flov data faor the profiles [cfz)

The flow conditions defined in the above window are upstream conditions. To define
downstream boundary, click on Reach Boundary Conditions. Then select Downstream
for Baxter River Lower Reach, click on Normal Depth, and enter 0.001.

Steady Flow Boundary Conditions

£ Set boundary far all profiles " Set boundary for one profile at a time

Available External Boundary Condhion Types

Rating Curve I Delete

Frnown W5, | Critical Depth |

Selected Boundary Condition Locations and Types

River Reach Profile Upztream D ownstream

Baxter River Upper Reach all Junchion=2

Baxter River Lower Reach all Junction=2

Tule Creek, Tributary all Junction=2

Steady Flow Feach-Starage Area Dptimization ... | Ok, I Cancel | Help |

[Enter to make the boundary for selected location normal depth.

Click OK. Save the flow data (give whatever title you like), and close the Steady Flow
editor. Now we are ready to run HEC-RAS!

Running HEC-RAS
In the main HEC-RAS window, click on Run—->Steady Flow Analysis..
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Steady Flow Analysis - |EI|E|

File Options Help

Plan: |Plan 07 Shot 1D |Flan M

Gearmetny Fils : IBa:-:ter Gearnetry

Steady Flow File :

Flow Regime
= Subcritical
= Supercritical
" Mixed
COMPUTE

Select the Subcritical Flow Regime, and click on the COMPUTE button. (Note: If you
get an error, you will need to modify geometry or flow data based on error messages to
run the simulation successfully).

Lef L

I Bauter Hov file

Flan Description

(L]

HEC-RAS Finished Computations o ] B
— Steady Flow Simulation
River: Baster River RS: 9732901
Reach: Upper Reach Mode Type:  Cross Section
Profle:  PF 3 |
Simuaton: 3/3 e

— Computation Messages

Steady Flow Simulation Verzion 3.1.3 May 2005
Firished Steady Flow Simulation

Tatal Corputation Time = 0 min 0.43 zec

After successful simulation, close the computation window and the steady flow window.
We will now export HEC-RAS results to ArcGIS to view the inundation extent, but
before this step, you should look at the output results and verify them in HEC-RAS. This
will help identify any errors in the input data and fix them, and run the simulation again,
if necessary.

Exporting HEC-RAS Output to HEC GeoRAS

To export the data to ArcGIS click on File=> Export GIS Data... in the main HEC-RAS
window. Since we ran the model with three profiles, we can choose which profile we
would like to export. Click on Select Profiles to Export button, and choose the profile
you want to export. For this exercise we will choose the one with maximum flow (PF3),
and accept the default export options.
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Export File: Iking\\-"enkatesh\ﬁeoHas\TutoriaI\baxter.HASexpolt.sdf Browse .. I

— Results Export Optian:

[V Ewport water Sufaces Select Profiles to Export I

[™ Esport ¥elocity Distribution Infarmation where available.

[T Use version 2.2 export format

— Geometry Data Expart Ophions

[V Esport River [Stream) Centerlines

ctioh Surface Lines Additional Properties
[~ Export User Defined Cross Sections [~ Reach Lengths
[all %5's except Interpolated #5's) [~ Bank Stations
[™ Esport Interpolated Cross Sections [~ Levess
{* Entire Crozs Section [~ Ineffective Areas
™ Charinel only [" Blocked Obstructions
Export Data | Cancel I Help I

Click on Export Data button, which will create a SDF file in your working directory.
Save the HEC-RAS project and exit. We will now return to ArcMap to create a flood
inundation map.

Flood inundation mapping

In ArcMap (if you closed baxter_georas.mxd earlier, open it) click on Import RAS SDF

file button & to convert the SDF file into an XML file. In the Convert RAS Output
ASCII File to XML window, browse to Baxter.RASexport.sdf, and click OK. The XML
file will be saved with the input file name in the same folder with an xml extension

Convert RAS Export SDF to XML

RasS SOF File: |D:"-.-’-'-.r|:1 georazibaster BAS export. sdf | Lj
FaS =ML File: |D:'\.-’-'-.r|:1 georazh\baxter BAS export. xml |

| ok || Clse |

Now click on RAS Mapping—> Layer Setup to open the post processing layer menu as
shown below:
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Layer Setup for HEC-RAS PostProcessing

Analsiz Type
) Existing Analysis

(%) New Analysis SteadyFlow
R&S GIS Export File D:vAre] Dhgearasbaster BAS export. sml
Tenain

Tenan Type (& TIN () GRID

© Single Temnan | D:MvrclOhgeorashGeoRASD atahbaxter_tin
© Muliple DTM Ties Layer =
Dutput Directorny D:hArc] thoeorashGeoRASD atasSteadyFlow
Geodatabaze
Rasterization Cell Size 20 [map units)
] ] l Help l ’ Cancel l

In the layer setup for post-processing, first select the New Analysis option, and name the
new analysis as Steady Flow. Browse to Baxter..RASexport.xml for RAS GIS Export File.
Select the Single Terrain Type, and browse to baxter_tin. Browse to your working folder
for Output Directory. HEC-GeoRAS will create a geodatabase with the analysis name
(Steady Flow) in your output directory. Accept the default 20 map units for Rasterization
Cell Size. Click OK. A new map (data frame) with the analysis name (Steady Flow) will
be added to ArcMap with the terrain data. At this stage the terrain TIN (baxter _tin) is
also converted to a digital elevation model (DEM) and saved in the working folder
(Steady Flow) as dtmgrid. The cell size of dtmgrid is equal to the Rasterization Cell Size
you chose in the layer setup window.

Next click on RAS Mapping-> Import RAS Data. Similar to during export, you will see a
series of messages during the import as shown below.
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¥H Import RAS Data [Z|
RAS File | |
Messages
~
Start Tirme I]x_*lyeps;age Message —3
BA15/202 211:41 PM Infarmative: Twing to create velocity paints...
BAR/2M2 217141 PM | Informative Trying to create ice points...
BA15/202 211:41 PM Infarmative: Twing to create shear stress painks...
BAR/2M2 217141 PM | Informative Trying to create stream power points. ..
BA5/202 217141 PM | Informative RAS output added to map...
BAR/2M2 21142 PM | Informative Bank points created...
BA5/2M2 217143 PM | Informative Layer symbology applied...
BA5/2002 21143 PM | Informative Converting TIM to raster...
BA5/202 217146 PM | Informative RAS data imported to GIS successfully!
*
@
[ Help l [ Cloze l

This will create a bounding polygon, which basically defines the analysis extent for
inundation mapping, by connecting the endpoints of XS Cut Lines.

After the analysis extent is defined, we are ready to map the inundation extent. Click on
RAS Mapping-> Inundation Mapping—> Water Surface Generation. Select PF3 (profile
with highest flow), and click OK.

This will create a surface with water surface elevation for the selected profile. The TIN
(tP003) that is created in this step will define a zone that will connect the outer points of
the bounding polygon, which means the TIN will include area outside the possible
inundation.
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At this point we have a water surface (tP003) TIN, and we have an underlying terrain
(baxter_tin and dtmgrid). Now we will subtract the terrain (dtmgrid) from the water
surface TIN, by first converting the water surface TIN to a grid.

Click on RAS Mapping-> Inundation Mapping->Floodplain Delineation using Rasters.
Again, select PF3 (profile with highest flow), and click OK. You will see a series of
messages during the execution. During this step, the water surface TIN (tP003) is first
converted to a GRID, and then dtmgrid is subtracted from the water surface grid. The
area with positive results (meaning water surface is higher than the terrain) is flood area,
and the area with negative results is dry. All the cells in water surface grid that result in
positive values after subtraction are converted to a polygon, which is the final flood
inundation polygon.

Inundation Polygon

/////// 7 //// // 7 '

(7 \“ P~ ., / .
\\ "DQ‘/‘/. ////}}}; '

After the inundation map is created, you must check the inundation polygon for its
quality. You will have to look at the inundation map and the underlying terrain to correct
errors in the flood inundation polygon. Sometimes you will realize (at the end!) that your
terrain has errors, which you need to fix in the HEC-RAS geometry file. The refinement
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of flood inundation results to create a hydraulically correct output is not covered in this
tutorial - this is an iterative process requiring several iterations between GIS and HEC-
RAS. The ability to judge the quality of terrain and flood inundation polygon comes with
the knowledge of the study area and experience.

Save the ArcMap document. Congratulations, you have successfully finished the HEC-
GeoRAS tutorial!
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